Управление питанием удаленное – Rmnt.ru

Содержание

Пример интеллектуального управления питанием группы серверов при помощи NetPing

Очень часто электропитание объектов IT-инфраструктуры малых и средних офисов является узким местом. Серверные комнаты малых и средних компаний часто не организованы, не соответствуют требованиям безопасности – как информационной, так и пожарной, и электротехнической и находятся в очень ограниченном пространстве. Такие условия могут приводить к аварийным ситуациям, чреватым простоями оборудования или, как минимум, к потенциальным опасностям, что может быть причиной лишнего беспокойства как за безопасность сотрудников, так и за безопасность бизнеса в целом. Для решения таких проблем предоставляется ряд эффективных практических методов улучшения работоспособности информационного оборудования в малых серверных комнатах. В данной статье мы рассмотрим возможность интеллектуального управления питанием небольшой группы серверов при помощи устройств распределённого питания NetPing. 

Задача

Необходимо обеспечить длительную работу небольшой группы серверов от источника бесперебойного питания, учитывая следующие условия:

  1. Если электропитание будет отключено в нерабочее время, необходимо исключить ситуацию, при которой аккумуляторы к началу рабочего дня (9:00) будут полностью разряжены. Т.е. отключить большинство потребителей и оставить только дежурные устройства. Возобновить работу оборудования нужно в случае восстановления электропитания серверной или в начале рабочего дня (9:00). В начале рабочего дня сервера должны быть включены вне зависимости от наличия электропитания;
  2. Если электропитание будет отключено в рабочее время, оборудование серверной комнаты должно работать до окончания рабочего дня (18:00 часов) или до полного разряда батарей ИБП;
  3. В случае отключения электропитания серверной IT-специалисты организации и заинтересованные лица должны получить SMS-уведомление на мобильный телефон.

Необходимое оборудование

  • Устройство распределённого питания NetPing 8/PWR-220 v3/SMS – 1 шт.;
  • Датчик наличия 220V – 1 шт.;
  • ИБП – 1 шт.;
  • ПК или сервер с низким энергопотреблением для работы управляющего скрипта – 1 шт.;
  • Сервера-потребители – 4 шт.;
  • Локальная сеть

Схема подключения

Алгоритм работы решения

  1. Скрипт на управляющем компьютере раз в 5 минут датчика наличия 220V, который подключён к устройству NetPing 8/PWR-220 v3/SMS;
  2. Если датчик наличия 220V сообщает о наличии питания – ничего не происходит;
  3. Если датчик наличия 220V сообщает об отключении питания, и событие отключения произошло в рабочее время – устройство распределённого питания отправляет SMS-уведомление о событии. Скрипт на управляющем компьютере не отправляет команду на выключение. Оборудование работает до полного разряда батарей, до возобновления питания или до окончания рабочего дня;
  4. Если датчик наличия 220V сообщает об отключении питания, и событие отключения произошло в нерабочее время — устройство распределённого питания NetPing 8/PWR-220 v3/SMS отправляет SMS-уведомление о событии. Скрипт на управляющем компьютере отправляет команду на выключение. При возобновлении электропитания или в начале рабочего дня скрипт отправляет на устройство распределённого питания команду включить розетки, к которым подключены сервера.

Реализация решения

Настройка устройства распределённого питания

Считаем, что устройство NetPing 8/PWR-220 v3/SMS настроено на работу в вашей локальной сети, и вам доступен его web-интерфейс. Ознакомиться с настройками устройства NetPing 8/PWR-220 v3/SMS можно в документации к устройству. Также к NetPing 8/PWR-220 v3/SMS необходимо подключить датчик наличия 220V. С правилами подключения датчиков к NetPing 8/PWR-220 v3/SMS можно ознакомиться в руководстве пользователя.

В нашей статье будем использовать следующие параметры:

Настроим уведомление по SMS для IT-специалистов и других заинтересованных лиц.

Переходим на страницу « через навигационное меню под шапкой web-интерфейса (1) и заполняем номера телефонов (2) в секции «Настройки GSM». Номера телефонов указываются в международном формате (начиная с +7). Всего можно указать 4 телефонных номера для получения уведомлений. Сохраняем введённые данные кнопкой «Применить изменения» (3):

Затем переходим на страницу «Ввод-вывод» через навигационное меню под шапкой web-интерфейса (1), нажимаем на кнопку «Настроить» для IO линии 1, к которой подключён датчик наличия 220V (2):

В открывшемся окне указываем нужные типы уведомлений о событиях на IO линии 1 (1). Подтверждаем сохранение изменений нажатием кнопки «Сохранить изменения» (2):

На этом настройку NetPing 8/PWR-220 v3/SMS для отправки SMS-уведомлений о событиях, регистрируемых датчиком наличия 220V, можно считать оконченной.

Подготовка управляемых серверов

Считаем, что в группу серверов с интеллектуальным управлением питани входят сервера со следующими параметрами:

IP адрес

192.168.1.180

192.168.1.181

192.168.1.182

192.168.1.183

Операционная система

Ubuntu 16.04.4 LTS

Windows Server 2012 R2

Windows Server 2012 R2

CentOS 7.0

Логин

tester

tester

tester

tester

Пароль

12345

12345

12345

12345

Для успешной работы скрипта на серверах с *nix операционными системами нужно установить сервер SSH (если не был установлен ранее). Для серверов под управлением операционных систем семейства Windows – установить пакет OpenSSH (описание установки OpenSSH. Также рекомендуем создать на всех управляемых серверах отдельного пользователя и дать ему права для удалённого подключения и выключения операционной системы (в нашем случае пользователь «tester»). BIOS управляемых серверов необходимо настроить так, чтобы при возобновлении питания сервера включались автоматически.

Создание управляющего скрипта

Для реализации программной составляющей нашей системы интеллектуального управления питани группы серверов напишем скрипт на скриптовом языке программирования BASH. Скрипт будет выполняться в консоли на ПК/сервере с OS Ubuntu. Управляющий скрипт также можно запустить и на компьютере за пределами локальной сети. В таком случае устройство NetPing 8/PWR-220 v3/SMS должно быть доступно через Интернет, и возможность доступа в Интернет должна быть энергонезависимой. О том, как сделать устройство NetPing 8/PWR-220 v3/SMS доступным через Интернет, можно прочитать здесь. 

Для работы скрипта на ПК/сервере с OS Ubuntu нужно установить утилиты Curl и Expect. Для этого выполним в консоли команды «sudo apt install curl» и «sudo apt install expect»

Затем создаём файл скрипта intellect_pdu.sh командой «nano intellect_pdu.sh». Скачать подготовленный файл скрипта можно здесь.

#!/bin/bash

##### В этой секции вы можете указать свои значения #####

#IP адрес устройства NetPing8/PWR-220v3/SMS
NPip="192.168.1.208"
#учетные данные для устройства NetPing8/PWR-220v3/SMS
NPuser="visor"
NPpass="ping"

#Учетные данные для серверов
user="tester"
pass="12345"

#Список серверов
serv="
192.168.1.180
192.168.1.181
192.168.1.182
192.168.1.183
"
###########################################################

while true

do
#Запрашиваем информацию о состоянии датчика наличия 220V:
io1=$(curl --silent --user $NPuser:$NPpass http://$NPip/io.cgi?io1)
sensor_220=${io1:20:1}
if [ "$sensor_220" -eq 0 ] #Если питания нет
then
echo "Питания нет"
d=$(date +%H) #Получаем текущее время.
if [ "$d" -lt "09" ]||[ "$d" -gt "18" ] #Если текущее время раньше 9 утра и позже 18 часов
then
echo "Нерабочее время - выключаем сервера"
#Выключаем сервера:
for S in $serv
do
expect -c "
spawn ssh [email protected]$S
expect \"*(yes/no)?*\" {send \"yes\r\"}
expect \"Password:\"
send \"$pass\r\"
expect \"*>\"
send \"shutdown -s\r\"
expect \"*shutdown:*\" {send \"sudo shutdown -h now\r\"}
expect \"*$user:*\" {send \"$pass\r\"}
expect eof " >> /dev/null
done
sleep 10m #Таймаут для завершения работы серверов.
#Отключаем розетки к которым подключены сервера:
for ((n=1; n<5; n++))
do
curl --silent --user $NPuser:$NPpass http://$NPip/relay.cgi?r$n=0 >> /dev/null
done
else
echo "Рабочее время - включаем сервера"
#Подаем питание на сервера:
for ((n=1; n<5; n++))
do
curl --silent --user $NPuser:$NPpass http://$NPip/relay.cgi?r$n=1 >>/dev/null
done
fi
else #Если питание есть
echo "Питание есть"
#Подаем питание на сервера:
for ((n=1; n<5; n++))
do
curl --silent --user $NPuser:$NPpass http://$NPip/relay.cgi?r$n=1 >>/dev/null
done
fi
sleep 5m
done

Сохраняем и делаем файл исполняемым при помощи команды «sudo chmod +x intellect_pdu.sh»:

Затем запускаем наш скрипт командой «./intellect_pdu.sh»:

И, если исходный код скрипта не содержит синтаксических ошибок, то в консоли будет отображены сообщения о состоянии датчика наличия 220V и действиях, которые выполняет скрипт. Скрипт настроен на бесконечную циклическую работу. Прервать выполнение можно нажатием кнопок «CTRL+C». На скриншоте ниже события для скрипта были смоделированы искусственно, чтобы отобразить все возможные состояния:

Для того, чтобы наш скрипт автоматически запускался при запуске ПК/сервера, нужно прописать его в автозагрузку. Для этого откройте файл rc.local командой: «sudo nano /etc/rc.local»:

Пропишите скрипт перед строчкой «exit 0» и сохраните файл:

Скрипт выполнится после загрузки системы.

Таким образом мы реализовали систему для интеллектуального управления питанием небольшой серверной.


www.netping.ru

IT-World: Дистанционное управление электропитанием

IT ExpertКак это сделатьСам себе админ

Сергей Грицачук | 05.04.2012

Когда нужно дистанционно включать устройства
Питанием каких устройств можно управлять дистанционно Как удаленно включить десктоп

Когда нужно дистанционно включать устройства
Каждый раз, когда вы находитесь вдали от дома, вам может понадобиться доступ к компьютеру, сетевому хранилищу или роутеру. Переслать документ, обновить список закачек торрент-клиента, просмотреть фотографии или записи, сделанные веб-камерой в ваше отсутствие, или попросту синхронизировать данные с облачным хранилищем – таких ситуаций много.
Конечно, без крайней необходимости оставлять электронное устройство включенным в сеть без надзора опасно, а не оставлять – значит лишить себя возможности пользоваться сетевыми ресурсами. Опасность есть, даже если вы отсутствуете недолго (скажем, на работе), но если предстоит длительная поездка или отпуск – рисковать, оставляя без надзора включенный компьютер, захотят немногие. Гораздо интереснее иметь возможность активировать его дистанционно, для того чтобы получить требуемую информацию.

Второй случай – сбой/зависание сетевого устройства (роутера или веб-камеры), вылечить который можно только перезагрузив его выключением/включением – тоже интересен для решения задачи дистанционного управления электропитанием.
И наконец, третий способ: уезжая в отпуск, вы хотите обезопасить жилище от посягательств злоумышленников, не только установив веб-камеру, но и создав иллюзию присутствия хозяев. Наблюдателю с улицы вряд ли придет в голову, что хаотическое включение осветительных приборов, телевизора, компьютера и елочной гирлянды – результат работы электроники, управляемой дистанционно.

Питанием каких устройств можно управлять дистанционно
Управлять дистанционно можно чем угодно, от компьютера до настольной лампы, если есть надежный канал в Интернет и достаточный для реализации такой задумки бюджет. Конечно, персональный компьютер включить/выключить проще всего – для этого существуют встроенные средства, а остальные, не столь разумные приборы, можно активировать через специальные устройства. 

 
Оснащенные функцией Power over the Net, они способны управлять и одной розеткой, и несколькими десятками – от этого зависит цена решения. По своей конструкции довольно просты: «снаружи» подсоединен сетевой кабель, «внутри» – электрические розетки, управляемые через веб-браузер. Выпускают их компании ATEN, Dataprobe, NetPing, Neol, Raritan. Главное условие для функционирования – мощность подключенного устройства не должна превышать возможности управляющего модуля, дополнительное – надежность интернет-канала. Если оба условия соблюдены, вы сможете подсоединить все, что требуется. С одним уточнением: подача питания позволит запустить прибор внешней командой (компьютер, сетевое хранилище) или он сам запустится после появления напряжения (роутер, модем).
Продвинутые устройства управления электропитанием предусматривают подачу напряжения на требуемую розетку не только вручную, но и по расписанию. Так удобно и создавать иллюзию присутствия хозяев в жилище, и перезапускать модем, роутер или точку доступа, когда это необходимо.
Программные средства в основном позволяют управлять включением/выключением персонального компьютера, для чего разработано достаточное количество эффективных механизмов – про них я расскажу подробнее.

Как удаленно включить десктоп
Самое простое решение – воспользоваться функцией Wake-On-LAN, которой оснащены практически все сетевые карты, как интегрированные, так и дискретные.

Даже если эта функция не реализована на встроенной сетевой плате, можно приобрести отдельную, но в таком случае убедитесь, что в BIOS (раздел Power Management) содержится пункт, позволяющий ее включить; может понадобиться и подключить сетевую плату к системной специальным проводом (обычно он входит в комплект поставки). Здесь есть нюанс: если сетевой адаптер или материнская плата поддерживают шину PCI версии 2.1, то необходим специальный трехпроводной кабель для соединения Wake-On-LAN-разъемов материнской платы и сетевого адаптера. Если и сетевой адаптер, и материнская плата имеют спецификацию PCI 2.2, кабель не нужен. 

После этих несложных манипуляций надо зайти в BIOS и активизировать данную опцию, а потом – приступать к экспериментам внутри сети.
Работает схема пробуждения несложно, но требует знания IP-адреса компьютера и МАС-адреса сетевой платы. По сути, с помощью специальной программы в локальную сеть отправляется широковещательный запрос, содержащий МАС-адрес сетевого адаптера спящего компьютера. Сетевой адаптер в режиме пониженного энергопотребления просматривает такие пакеты и при обнаружении специализированной последовательности подает команду на включение питания.
Если в локальной сети данный эксперимент прошел успешно, можно приступать к тестированию удаленной работы функции. Если вы пользуетесь роутером, его следует предварительно настроить, разрешив прохождение широковещательных запросов на конкретный компьютер. Как правило, указывается в качестве адреса что-то наподобие IP Address: 192.168.0.255 (не адрес компьютера!), порт – 9, протокол – UDP. Подробнее можно прочитать в руководстве пользователя к модели роутера либо на сайте, посвященном этой тематике. Программ-«будильников» в Интернете достаточно, также пригодятся и онлайн-ресурсы.
Этот способ хорош для многих компьютеров, но те, у кого платформа поддерживает технологию Intel AMT (Active Management Technology), могут получить значительно больше сервисов, соединившись с удаленным компьютером при помощи технологии Intel vPro.
Для реализации такого способа лучше всего подойдет программа Radmin: она позволяет не только включить ПК удаленно, но и проконтролировать весь процесс запуска, в том числе (при необходимости) загрузиться с компакт-диска или изменить настройки в BIOS. Примечательно, что версия Radmin Viewer бесплатна, но ее возможностей по удаленному управлению запуском/остановкой компьютера более чем достаточно для решения многих задач. 

Разумеется, они предполагают и доступ к интерфейсу управления удаленным компьютером: если вы решили включить ПК механизмом Wake-On-LAN, придется дополнительно активировать встроенный в ОС сервис удаленного доступа к рабочему столу.
Для компьютеров, не оснащенных данной технологией, пригодится специальная плата ATEN IP8000 PCI – она позволит подключить отдельный сетевой кабель и адаптер электропитания (обеспечив полную независимость от ПК) и предоставит пользователю полный набор функций удаленного управления. Благодаря наличию собственного процессора и независимого электропитания, ATEN IP8000 PCI управляет даже зависшим компьютером, обеспечивая его дистанционную перезагрузку. 

 
И наконец, последний (и самый надежный) способ решения задачи – аппаратный (коммутатор розетки). Не секрет, что в любом из описанных выше способов системный блок остается подключенным к электропитанию и его БП будет продолжать находиться под напряжением. Хоть и в дежурном режиме, но все же это не снижает риска возникновения пожара, тогда как коммутатор розетки полностью отключает все цепи. Конечно, сам он остается под напряжением, но мощность встроенных цепей невелика, да и размеры позволяют разместить в защищенном месте – а значит, риск пожара меньше. Такое устройство, как NetPing /PWR-220, будучи подключенным к Интернету, не только управляет питанием компьютера, но и отслеживает состояние роутера, периодически проверяя, не завис ли он. В случае если последний перестанет отвечать на запросы, прибор автоматически перезапустит его.  Непосредственно компьютер можно включить как любым из двух вышеприведенных программных методов, так и автоматически: достаточно в BIOS найти опцию, отвечающую за состояние компьютера после возобновления подачи напряжения питания, и выставить ее значение в Always ON. Тогда после подачи напряжения ПК сразу включится и начнет загружаться.
Аппаратный способ – самый надежный и универсальный, если канал в Интернет достаточно надежный, а роутер не склонен к зависаниям. Для страховки можно подсоединить к переключателю управления питанием отдельный (резервный) канал, например, беспроводной связи – и тогда даже при проблемах с роутером вы без труда получите доступ к управлению его питанием и перезапустите вручную. Конечно, если бюджет разрешает приобрести хотя бы восьмипортовый модуль управления электропитанием посредством IP, то количество и простота решаемых задач увеличатся.

Выводы
Несмотря на то, что аппаратное решение по управлению электропитанием считается самым надежным, оно не лишено и недостатков. Прежде всего, это высокая цена: дополнительные расходы на новое устройство, возможная оплата услуг специалиста по подключению и настройке, приобретение еще одного канала связи и тому подобное делают его приемлемым для тех, кому важно обеспечить высокую надежность и бесперебойный доступ к ресурсам оставленного без присмотра компьютерного хозяйства.
Если же такие глобальные задачи не ставятся, целесообразнее обойтись программными способами. Они хороши для тех случаев, когда ваш компьютер выполняет роль торрент-клиента или FTP-сервера, для чего не обязательно иметь полноценный доступ к рабочему столу Windows, хотя и это легко сделать без какого-либо стороннего софта.
Для тех же, кто готов пойти на разумный компромисс, лучшим вариантом будет Radmin (конечно, если компьютер оснащен поддержкой Intel AMT): в дополнение к возможности включать/выключать компьютер, вы получите удаленный доступ ко всем его ресурсам. Зайдя на собственный рабочий стол удаленно, вы будете управлять остальными сетевыми устройствами – NAS или веб-камерами.

www.it-world.ru

Удаленное управление электропитанием 220 вольт на базе Mikrotik RB750UP. — asp24.ru

Системы удаленного управления электропитанием 220 вольт для включения или выключения оборудования представлены на рынке многими производителями, в том числе и отечественными – NetPing 2/PWR-220, Икар-ДУ,Aviosys IP Power 9258 S, Planet IPM-8002-EU. Но стоимость подобного оборудования достаточно высока, а функционал встроенного программного обеспечения очень низок. Все, что могут большинство решений – проверять на доступность адрес с помощью команды ping. Но в условиях реальной эксплуатации часто возникает потребность в более гибкой системе проверок работы оборудования и переключения каналов связи, что реализовать с помощью существующих на рынке устройствах невозможно.

Программное обеспечение этих устройств не достаточно стабильное и иногда дает сбои, выраженные в виде самопроизвольного отключения нагрузки или зависаний, что не позволяет использовать их в труднодоступных местах.

Функционал операционной системы Mikrotik Router OS очень большой и стабильность работы хорошая, но в линейке оборудования этого производителя нет устройств управлением питания 220 вольт.

Если готовых устройств нет – можно сделать самостоятельно, на базе нового маршрутизатора со встроенным PoE коммутатором – Mikrotik RB750UP. Это совсем не сложно. При этом у созданного решения может быть одна, две, три или четыре управляемых розетки. Мощность 1500-2000 ватт на каждую.

Для сборки решения понадобятся следующие компоненты:

  1. Блок питания 12 вольт – для запитывания устройства и реле.
  2. Розетка – для подключения управляемой нагрузки.
  3. Шнур питания – для подключения к сетевой розетке.
  4. Автомобильное реле 75.3777 с колодкой – для управления питания нагрузкой.
  5. Моток изоленты – для изолирования оголенных частей проводов.
  6. Кусок кабеля витой пары – для подключения реле к микротику.
  7. Mikrotik RB750UP – для управления.

 

Кабель витая пара с одной стороны обжимаем стандартным образом – БО, О, БЗ, С, БС, З, БК, К и подключаем к микротику. С другой стороны в разъем обжимаем только БО, О, БЗ и З. Синюю и коричневую пары разделяем и оголяем провода. Разъем можно использовать для подключения любого сетевого устройства.

 

Блок питания нужно использовать 12 вольт, 1 ампер или более мощный. Реле рассчитаны на напряжение 12 вольт. По этому нельзя применять блок питания на 24 вольта из комплекта поставки RB750U.

 

Сетевая розетка, в данном случае с возможностью установки на DIN рейку и заземлением. Под контакты удобно вставлять провода и зажимать специальными винтами. Купить розетку можно в любом магазине электротоваров.

 

Автомобильное пяти контактное реле 75.3777 и колодку к нему можно купить в автозапчастях. Спрашивать у продавца нужно – пяти контактное реле на 30 ампер с колодкой.

Из колодки выходят 5 проводов. На реле нарисована схема подключений.

  • Контакты 86 и 85 (черный и коричневый провод) используются для подачи питания на катушку реле, при этом происходит включение или отключение подключенной нагрузки по другим проводам.
  • Контакт 30 вводный, на него подается питающее напряжение нагрузки, красный провод.
  • Контакт 87 замыкающий, при включении реле на нем появится питающее напряжение, зеленый провод.
  • Контакт 88 размыкающий, при включении реле на нем пропадет питающее напряжение, желтый провод.

Обратите ВНИМАНИЕ – контакты на реле и на колодке отображены зеркально.

 

Синий и коричневый кабели витой пары соединяются к черному и коричневому кабелю колодки реле. С их помощью будет подаваться питание на электромагнитную катушку.

 

Красный кабель подключается к контакту в розетке.

 

К другому контакту розетки подключается подводящий кабель питания. В данном случае синий.

 

Второй провод от кабеля питания соединяется с желтым кабелем от реле. При этом во время включения реле будет происходить отключение подключенной к розетке нагрузки. Если нужно сделать наоборот – что бы при подаче питания на реле включалась и нагрузка, следует коричневый провод от подводящего кабеля соединить с зеленым проводом от реле. Но делать так не стоит, ведь при отключении питания устройства будет отключаться и нагрузка.

 

В итоге получилась следующая схема соединений. Все оголенные провода нужно замотать изоляционной лентой.

 

Для проверки работоспособности схемы собран не сложный тестовый стенд. В розетку подключена лампа, кабель питания подключен в сетевой фильтр, туда же и блок питания от микротика. Витая пара для управления розеткой подключена в 5-й сетевой порт, кабель управления в первый порт. Перед подачей питания проверьте еще раз надежность и правильность подключений.

 

При включении питания сразу загорается лампа – ведь питание на порту PoE отключено.

 

Это видно на Mikrotik RB750UP – горит только индикатор подключенного первого сетевого порта.

 

Теперь включаем на порту 5 питание PoE – лампа выключается.

 

На микротике загорается красный индикатор, сигнализирующий о том, что на 5-й порт подается питание PoE.

 

Видно, что управление питанием 220 вольт подключенной нагрузки работает должным образом.

Управление нагрузкой можно осуществлять в разделе INTERFACES в свойствах сетевого порта. Для этого в пунктеPoE Out меняя значения On и Off включать и выключать питание. Установка значения Auto приведет к отключению питания порта, т.к. произойдет проверка подключенной нагрузки на соответствие режима пассивного PoE, которое реле не пройдет.

 

Управлять питанием порта можно и в окне терминала в разделе New Terminal.

Можно вводить следующие команды для управлением состояния порта:

  • /interface ethernet set ether5 poe-out=forced-on – для выключения нагрузки.
  • /interface ethernet set ether5 poe-out=off – для включения нагрузки.
  • /interface ethernet set ether5 poe-out=auto – в данном случае дано для ознакомления.

 

Кроме ручного управления питанием подключенной нагрузки, можно сделать автоматическую проверку доступности с перезапуском по питанию. Для этого в разделе SYSTEM—+SCRIPTS нужно создать новый скрипт в котором в поле Source ввести следующие команды:

  • #220v Script;
  • :local PINGCOUNT 5;
  • :local PINGIP «10.0.0.11»;
  • :local POEINTERFACE «ether5»;
  • :log info message=»START PING TO $PINGIP»;
  • :local PINGRESULT [/ping $PINGIP count=$PINGCOUNT];
  • :if ($PINGRESULT > 0) do={
  • :log info message=»PING TO $PINGIP OK»;
  • } else={
  • :log info message=»PINGTEST $POEINTERFACE 220V OFF»;
  • /interface ethernet set $POEINTERFACE poe-out=forced-on;
  • :delay 20;
  • :log info message=»PINGTEST $POEINTERFACE 220V ON»;
  • /interface ethernet set $POEINTERFACE poe-out=off;
  • :delay 10;
  • }
  • :log info message=»PING TO $PINGIP END»;

Где:

  • PINGCOUNT – количество отправляемых запросов для проверки доступности. Нужно устанавливать как минимум 5, что бы при случайных потерях не произошла не запланированная перезагрузка устройства.
  • PINGIP – сетевой адрес для проверки доступности. В нашем случае 10.0.0.11.
  • POEINTERFACE – сетевой интерфейс, к которому подключено контролируемое устройство. В нашем случае ether5. Указывать имя надо так, как назван интерфейс, большие и маленькие буквы считаются различными, и указав Ether5ничего работать не будет.
  • Log info message – сообщения, которые добавляются в лог файл устройства, при выполнении скрипта.

 

Для запуска выполнения команд, с определенным интервалом, в разделе SYSTEM—+SHEDULER нужно создать новое расписание, нажав на +. В открывшемся окне нужно в пункте Start Time выбрать вместо времени – Startup. Тогда при включении устройства сразу начнется отсчет времени на запуск этого расписания. В пункте Intervalуказывается интервал запуска, указываем там 00:01:00 – то есть запускать раз в минуту.

В текстовом поле On Event указываем команду запуска созданного ранее скрипта:

  • /system script run script1

 

После создания скрипта и запуска его в планировщике заданий, будет происходить автоматическая проверка подключенного устройства. Если оно вдруг станет не доступно по сетевому адресу – питание 220 вольт будет отключено и через некоторое время включено снова. Произойдет перезапуск подключенного оборудования.

Так же управлять устройством можно удаленно, например по Telnet или SSH.

Если нужно управлять питанием нескольких подключенных устройств – нужно собрать нужное количество реле с розетками и подключить к свободным PoE портам микротика.

Из Mikrotik RB750UP получилось многофункциональное устройство, которое может не только управлять питанием подключенных к ней устройств с помощью PoE, но и управлять питанием любых устройств, имеющих питание 220 вольт. При этом доступен весь спектр возможностей операционной системы Router OS. Разместить его можно в любом удобном корпусе.


Часть вторая. Обзор и настройка LM Power Manage System.

Производители различного оборудования постоянно увеличивают надежность работы своих устройств, что позволяет ему долгое время работать без вмешательства обслуживающего персонала. Но иногда, даже надежное оборудование, может дать сбой. Причины возникновения неисправности всегда разные и нельзя полностью исключить все возможные ситуации, которые могут повлиять на его работоспособность. Если оборудование установлено в серверной комнате, в которую есть круглосуточный доступ, постоянно находится дежурный инженер – то перезагрузить оборудование можно в течении 5 минут. Но если доступ к нему затруднен, или требует административных проволочек, таких как выписка пропусков и различных согласований. Самые большие сложности может принести сбой оборудования, установленного в труднодоступных местах, или на расстоянии в несколько десятков, или сотен километров.

Для перезагрузки зависшего устройства можно отправить инженера, который потратит время и деньги на оплату проезда. А можно поставить систему управления питанием, которая автоматически сделает всю работу – перезагрузит устройство в случае отсутствия доступа на него.

Рассмотрим систему управления питания более подробно.

 

LM Power Manage System – система управления питания с 4 не зависимыми розетками 220 вольт, встроенным 5 портовым маршрутизатором Mikrotik RB750UP в металлическом корпусе высотой 1U с возможностью установки в телекоммуникационную стойку.

 

Для демонстрации возможностей системы подключим к управляемым розеткам блоки питания со светодиодным индикатором работы. Видно, что без каких либо настроек питающее напряжение подается на подключенные устройства. Если по каким-то причинам система перестанет работать – подключенное оборудование продолжит свою работу.

 

Блоки питания, подключенные к Power Manage System, показывают наличие питающего напряжения.

 

Отключаем первый порт питания – видно, что индикатор первого подключенного устройства погас.

 

Загорелся индикатор наличия питания PoE на 2 порту устройства. Включается реле и снимается напряжение с розетки.

 

Отключаем в настройках системы управления питанием 3-й порт, о чем сигнализирует погасший индикатор устройства, подключенного в соответствующую розетку.

 

Индикатор Mikrotik RB750UP показывает наличие питания PoE на 2 и 4 портах.

 

Отключаем питание всех четырех розеток, все индикаторы подключенных устройств погасли.

 

Все индикаторы наличия питания на реле включены, все розетки отключены от питающего напряжения 220 вольт.

 

Теперь отключаем питание со всех портов Mikrotik RB750UP и подача напряжения на розетки возобновляется.

 

Встроенный 5 портовый маршрутизатор можно использовать для решения различных задач. В распоряжении все возможности операционной системы Mikrotik RouterOS. Так же все порты можно объединить в режиме обычного коммутатора.

 

Каждый сетевой кабель подключается к соответствующему порту Mikrotik RB750UP. Нумерация портов идет слева на право.

 

Наличие сетевого соединения на каждом порту отображается индикаторами устройства. Но там нумерация идет в обратном порядке.

Теперь рассмотрим управление портами со стороны операционной системы RouterOS.

С помощью Winbox заходим на устройство и видим список сетевых интерфейсов.

 

В свойствах интерфейсов Ether2, Ether3, Ether4 и Ether5 есть пункт управления подачей питания – PoE Out, который может принимать следующие значения:

  • Auto – питание на порт подается в случае подключения к нему устройства с питанием по пассивному PoE.
  • Off – питание на порту отключено.
  • On – питание на порту включено принудительно.

При изменении настройки автоматически изменяется состояние порта. Но при включении питания, прежде чем оно будет подано на порт, происходит задержка 5 секунд.

 

Управлять подачей питания можно и из терминала, вводя следующие команды:

  • Interface Ethernet set ether2 poe-out=forced-on – для выключения розетки.
  • Interface Ethernet set ether2 poe-out=off — для включения.

 

Имя сетевого порта соответствует подключенной розетке. Сетевой порт Ether2 управляет первой розеткой, порт Ether3 – второй, Ether4 – третьей, а Ether5 – четвертой.

 

Аналогично можно управлять питанием подключенной нагрузки удаленно, через Telnet или SSH, подключившись по IP адресу микротика.

 

Для создания командных файлов, или при разработке программного обеспечения для контроля и управления питанием, можно подавать указания из командной строки. Например, с помощью входящей в комплект поставки программы PuTTY – plink.

Синтаксис команд простой:

  • Plink –l admin –pw  -batch 192.168.0.123 /interface Ethernet set ether2 poe-out=forced-on
  • Plink –l admin –pw  -batch 192.168.0.123 /interface Ethernet set ether2 poe-out=off

Первая команда отключает нагрузку, вторая – включает.

  • -l admin – логин для доступа на устройство
  • -pw pass – пароль. В данном примере пароль не указан, поэтому после –pw ничего не написано.

 

Для автоматической проверки доступности подключенных устройств, используется скрипт, который создается в разделе SYSTEM—+SCHEDULER:

  • # 220v Script;
  • :local PINGCOUNT 5;
  • :local PINGIP «10.0.0.11»;
  • :local POEINTERFACE «ether5»;
  • :log info message=»START PING TO $PINGIP»;
  • :local PINGRESULT [/ping $PINGIP count=$PINGCOUNT];
  • :if ($PINGRESULT > 0) do={
  • :log info message=»PING TO $PINGIP OK»;
  • } else={
  • :log info message=»PINGTEST $POEINTERFACE 220V OFF»;
  • /interface ethernet set $POEINTERFACE poe-out=forced-on;
  • :delay 20;
  • :log info message=»PINGTEST $POEINTERFACE 220V ON»;
  • /interface ethernet set $POEINTERFACE poe-out=off;
  • :delay 10;
  • }
  • :log info message=»PING TO $PINGIP END»;

Где:

  • PINGCOUNT – количество отправляемых запросов для проверки доступности. Нужно устанавливать как минимум 5, что бы при случайных потерях не произошла не запланированная перезагрузка устройства.
  • PINGIP – сетевой адрес для проверки доступности. В нашем случае 10.0.0.11.
  • POEINTERFACE – сетевой интерфейс, к которому подключено контролируемое устройство. В нашем случае ether5. Указывать имя надо так, как назван интерфейс, большие и маленькие буквы считаются различными, и, указав Ether5,ничего работать не будет.
  • Log info message – сообщения, которые добавляются в лог файл устройства, при выполнении скрипта.
  • DELAY – задержка. При включении в настройках подачи напряжения на порт, сама подача произойдет через несколько секунд. Поэтому нужно вносить задержку. Уменьшать ее ниже 10 секунд нельзя.

Указывается интервал запуска, например 00:01:00, указывается название, например Ping ether2 и самое главное -Start Time указать Startup, что бы скрипт запускался сразу после загрузки устройства.

 

Для создания аналогичного скрипта контроля другой розетки, нажимаем кнопку Copy сбоку и получаем копию, которую можно изменить.

 

Меняем название на Ping ether3, IP-адрес для контроля – 10.0.0.100 и сетевой интерфейс на ether3 – для управления второй розеткой.

 

В списке отображены 2 скрипта, запускающихся автоматически и контролирующие нагрузку к подключенным розеткам.

 

Установить IP адрес на устройстве можно в меню IP—+ADDRESS. Нажимаем на + и в открывшемся окне указываем адрес и интерфейс, на котором он будет работать. С него будут отправляться пинги для контроля работоспособности устройств. Можно установить несколько адресов одновременно.

 

Теперь в случае каких-то проблем с оборудованием, произойдет автоматический перезапуск по питанию. И не придется отправлять инженера на решение таких простых проблем.

С помощью LM Power Manage System – системы управления питанием, или управляемого свича питания, как его еще можно назвать, и операционной системы Mikrotik, легко реализовывать различные способы подключения к сети для обеспечения удаленного доступа:

    • 1.Доступ по прямому адресу. Когда у устройства есть белый или серый IP-адрес, который всегда доступен. По нему оператор может подключаться к системе для контроля и изменения параметров.
    • 2.Доступ через проброс портов. В этом случае так же нужен один, постоянно доступный IP-адрес.
    • 3.Доступ через несколько адресов – к двум или более портам подключаются различные операторы связи, и в случае не доступности одного из них, управление будет происходить через оставшиеся.
    • 4.Доступ по туннельным протоколам – PPPoE, PPTP, L2TP, SSTP при отсутствии прямого адреса. Устройство будет автоматически подключаться к удаленному серверу и управление можно осуществлять по выданному ему адресу.
    • 5.Доступ через сеть сотовых операторов через 3G модем. Так же возможна работа по прямому адресу, либо через туннельный протокол.
    • 6.Работа в качестве маршрутизатора для доступа к другому подключенному оборудованию в аварийном режиме. Через любую сеть можно осуществлять проброс каналов связи на уровнях L3 или L2. Инженер может пробросить физическую сеть через Интернет, например для осуществления доступа к устройству после сброса, когда настройки сети установлены по умолчанию и шлюз на маршрутизатор не указан.

Видно, что даже в случае аварии на магистральных сетях, можно получить доступ на устройство для перезапуска неисправного оборудования. В некоторых случаях, быстрая перезагрузка зависшего оборудования, может сэкономить большую сумму денег, которая с лихвой окупит стоимость устройства — LM Power Manage System.

Подключать к розеткам можно не только сетевое оборудование, но и кондиционеры, вентиляционное оборудование, освещение, даже сирену для сигнализирования о неисправностях или аварийных ситуациях.

Для управления мощными или 3-х фазными нагрузками к розеткам подключаются контакторы, в этом случае максимальные токи устройством не ограничиваются.

Кроме управления нагрузкой, с помощью реле можно управлять запуском генераторов, а так же любой другой автоматики.


© lanmart

asp24.ru

Power over NET: удаленное управление электропитанием

О том, как заменить монитор и клавиатуру сервера коммутатором KVM over IP, наши читатели уже хорошо знают, в частности и из предыдущих публикаций. Поскольку удаленное администрирование сетевых компонентов – тема весьма актуальная для многих специалистов, в этой статье речь пойдет об устройствах, позволяющих системному администратору управлять режимом питания обслуживаемых модулей.

Входной ток (общий вход) 220–240 В, 50/60 Hz 10 А

Выходной ток
220–240 В, 50/60 Hz 10 А

Индикаторы

питания на выходных розетках 8 (оранжевых)

удаленного доступа 8 (зеленых)

связи 1 (зеленый)

скорости 10/100 Мbps 1 (оранжевый/зеленый)

питания 1 (синий)

тока 1 (красный)

идентификатора станции 2×7-сегментных (желтых)

Энергопотребление

без нагрузки 16 Вт

максимальная нагрузка 2300 Вт

Габариты (Ш×Г×В ) 43,2×24,9×4,45 см

Предоставлен компанией www.onix.kiev.ua

Удобное управление, широкий набор функций

Невозможно определить расписание для группы розеток, всего один порт RS-232

Нередко специалисты, обслуживающие крупные корпоративные сети, скептически относятся к системам удаленного управления сетевыми компонентами, мотивируя это тем, что «модем удаленно не включишь», все равно нужно бежать в серверную.

Согласиться с таким утверждением может только человек, незнакомый с целым классом разработок, получивших в профессиональной среде прозвище «деглюкаторы», или, что более корректно, «устройства удаленного управления питанием».

Практически любому системному администратору известно как минимум об одном представителе данного класса – источнике бесперебойного питания, ИБП. Действительно, он позволяет решить много проблем, связанных с электроснабжением серверного оборудования, вплоть до интеллектуального выключения по команде операционной системы.

Конечно, для того чтобы включить питание, понадобится присутствие оператора, что не всегда удобно или желательно. Кстати, иногда возникает необходимость перезапускать зависший модем, коммутатор или другое сетевое устройство, причем зачастую сделать это можно только с помощью тумблера Power.

Есть еще целый набор задач, которые приходится выполнять более или менее регулярно. Объединяет их одно – все они связаны с операцией подачи/снятия напряжения питания. Вот далеко не полный список таких задач: включение/выключение устройства в заданное время; перезапуск устройства; контроль над потребляемым током; безопасная перезагрузка операционной системы с выключением питания; управление режимом питания устройства или группы устройств по графику и т. д. Причем неплохо было бы иметь возможность производить все эти операции как удаленно, так и локально, желательно с помощью стандартных средств – терминала (консоли), telnet-клиента и Web-браузера.

Типовая схема подключения коммутатора. Дополнительно можно подсоединить ИБП, модем или локальный терминал
Altusen Power over the NET PN9108 позволяет организовать удаленное управление питанием от 8 до 128 (с каскадированием) устройств

Конечно, частично решить некоторые проблемы можно традиционными способами – например выключить сервер в заданное время средствами операционной системы, а включить, – используя функции BIOS. Или приобрести коммутационное оборудование, автоматически перезапускаемое при исчезновении связи. Но это лишь частные случаи – есть гораздо более изящное решение, позволяющее реализовать не только перечисленные выше, но и многие другие идеи.

Здесь уместно отойти от слова «решение» и перейти к термину «устройство», поскольку вся упомянутая функциональность даже с долей избыточности присуща одному модулю с названием PON – Power over NET, разработанному компанией ATEN International, – Altusen Power over the NET PN9108. Подобные устройства производят и другие компании – к примеру, APC и Raritan, но на момент подготовки материала их не удалось заполучить для тестирования.

Основные функции, выполняемые этим модулем, условно делятся на два подкласса – обеспечение управления питанием восьми розеток и поддержка управления по протоколу TCP/IP подручными средствами – Web-браузером и Telnet. В общем-то, классическое описание можно было бы на этом и закончить, отослав читателя к таблице с характеристиками, но тогда из поля зрения выпало бы самое интересное – как взаимосвязаны между собой эти две функции и чего можно добиться с их помощью.

Подключение и настройка

Коммутатор ATEN подключается довольно просто. Фактически достаточно подсоединить к его розеткам нагрузку, а к управляющим портам – соответственно локальную консоль и сетевой (LAN) кабель, и после этого начинать работу. По умолчанию все розетки включены, так что подключенные устройства заработают сразу.

Меню «Конфигурация» позволит определить группы, выбрать режим работы розеток и настроить ИБП

В первую очередь следует продумать, что использовать в качестве локальной консоли – дело в том, что в разъем RS-232 можно включить не только терминал, но и модем. При возникновении непредвиденных ситуаций связь с устройством для проведения требуемых операций будет поддерживаться по телефонной линии.

При необходимости к PN9108 можно подключить управляемый ИБП, но в этом случае придется отказаться от консоли (модема), поскольку управление ИБП осуществляется через тот же порт RS-232.

После подключения всего необходимого как минимум придется сменить адрес, логин и пароль, выставить дату и время, а также завести добавочных пользователей, назначив им соответствующие полномочия. Удобнее всего управлять коммутатором с помощью Web-интерфейса. Практически все настройки выполнены в виде удобных в работе графических форм, например, для переключения любой розетки достаточно щелкнуть мышкой по соответствующему значку.

Простейшие операции

Управление PN9108 возможно с помощью программы Telnet. Но Web-интерфейс намного удобнее!

Конечно же, под простейшими подразумеваются основные методы управления подключенными устройствами – включение, выключение или перезапуск. Для тех из них, которые требуют предварительной остановки ОС, придется дополнительно подсоединить управляющий кабель – это обеспечит корректное отключение сервера.

Кроме того, команду допускается подать сразу на все розетки или на их группу (всего до четырех), предварительно определив ее в подменю «Configuration». Здесь же настраиваются дополнительные параметры для каждой из розеток – скажем, задержка при включении/выключении или реакция на входящий звонок.

Включение по расписанию

Настройка расписания дает возможность включить, выключить или перезапустить подключенное устройство в нужное время без участия оператора
На основе истории событий можно построить отчет о режиме работы оборудования
Окно монитора информирует не только о статусе розеток, но и о потребляемом токе

Подменю «Schedule» позволяет производить переключение устройств по заданному графику для каждой розетки в отдельности. Причем в расписание допускается вносить время выключения и перезапуска на каждый день недели. Использовать этот режим можно для различных целей – например, отключения целых сегментов сетей в праздничные и выходные дни, включения модемов для приема входящих соединений или технологического перезапуска сервера в определенное время.

Мониторинг

Благодаря встроенной системе контроля оператор получает возможность отслеживать не только состояние отдельной розетки, но и такие параметры, как потребляемый ток, активные сессии пользователей и операции, произведенные с устройством на протяжении выбранного интервала времени. На основе анализа данных лог-файла можно сформировать полный отчет о картине электропитания подключенных устройств, сделать выводы о необходимости внесения изменений в конфигурацию ИБП или грамотно распределить полномочия операторов.

Еще одной интересной и весьма полезной функцией станет точное определение времени работы конкретного устройства – такая статистика очень пригодится не только бухгалтерии для расчета коэффициента износа ресурса, но и сотрудникам техотдела для прогнозирования плановых работ по замене или модернизации оборудования, что существенно повысит надежность администрируемой системы в целом.

Разные мелочи

В описании функций и полезных особенностей PN9108 стоит упомянуть также об управлении с передней панели. В частности, специальными кнопками принудительно устанавливается режим контроля для каждой розетки – отключив удаленное управление, можно обезопасить подключенное устройство от случайного включения или выключения: интерфейс отобразит подсказку о недоступности данного порта.

Если имеющихся розеток недостаточно, можно добавить дополнительные модули – коммутатор допускает каскадирование до 15 устройств и управление 128 выходами. При этом все модули и их текущее состояние будут отображены в окне Web-интерфейса под соответствующими номерами.

Коммутатор PN9108 допускает монтирование в стойку с возможностью разнесения передней и задней панели – они соединяются между собой кабелем. При эксплуатации в виде отдельного модуля этот кабель убирается в специальную нишу.

Также стоит отметить, что Altusen PN9108 в сочетании с коммутатором COM-портов и ранее описанным KVM-коммутатором Altusen KN9000 (itc.ua/21314) предназначен для создания весьма мощной и разветвленной инфраструктуры, которая позволит не только осуществить полноценное удаленное управление сетевыми компонентами, но и сведет к минимуму необходимость присутствия операторов в серверной. А это положительно скажется на защищенности узловых объектов сети и обеспечении надлежащего уровня секретности.

itc.ua

Заметки им.Ibice: Удаленное управление питанием: миф или реальность?

Удаленное управление питанием: миф или реальность?

В последнее время меня просто ужасно раздражает один их офисных серверов. Его проблема заключается в дурацкой сетевой карте, драйвер которой есть практически в любом ядре Linux старше 2.6, но который запускается с таким треском, что иногда кажется, что лучше просто применить какую-то внешнюю сетевую карту. В рабочее время это особенных проблем не вызывает, так как сервер можно лишний раз перезагрузить либо заставить еще раз загрузить нужный модуль, весело же в нерабочее время, если вдруг этот сервер зачем-то понадобится. Он может бесперебойно работать по нескольку месяцев, а потом начинается шоу-программа. Драйвер вылетает при перезагрузке, соответственно, стоит только системе установить обновление, требующее перезагрузки, либо же при первом перебое с электричеством сервер уходит в аут до следующего рабочего дня, когда его по-старинке снова перезагрузят нажатием на кнопку на корпусе. В последнее время у меня появились жалобы на то, что офисный VPN там тоже работает не так, как положено, поэтому сегодня я решил этой проблемой заняться. Что же вы думаете произошло после перезагрузки? Все верно — сервер отправился спать до завтра, никаких рычагов влияния на него больше у меня нет. С момента этого перебоя я задался вопросом, неужели в 2014-ом году у нас нет какой-то возможности удаленно перезапустить зависшую машину, стоящую при этом не в серверной, где все, само собой, готово к удаленному управлению.

К моему удивлению, оказалось что наука в наших широтах все-таки семенит в сторону светлого будущего и уже создала целых несколько способов удаленного управления питанием, некоторые из них я хочу рассмотреть в этой заметке. Для начала рассмотрим готовые к употреблению решения.

GSM-розетка. Очень интересная штука, в которую вы вставляете SIM-карту и управляете питанием со своего мобильного телефона. Таких розеток есть великое множество и делятся они в том числе и по сложности. Простейшие просто переключают состояние питания при входящем звонке. Согласитесь, не лучший вариант, так как некоторые операторы (со смайликами в логотипе, например) любят по ночам прозванивать неактивных абонентов типа «не туда попали», да и вообще никто не исключает возможность действительно ошибочного звонка либо «Виасата». Не хотелось бы, чтобы наш сервер отключался по велению оператора колл-центра какой-нибудь предлагалки.

Более развитые GSM-розетки поддерживают включение/отключение питания по специальной команде, отправленной при помощи SMS-сообщения. Это уже лучше, особенно если такая команда будет уникальной для каждого такого устройства, или, например, будет содержать какой-то пароль: «ON 1678». Существуют также розетки даже с голосовым меню, но это уже неадекват какой-то. Вот эта, к примеру, розетка, стоимостью в чуть более, чем восемь сотен гривень, передает данные на сервер производителя через GPRS, благодаря чему ей нужен будет еще и специальный тарифный план с безлимитным Интернетом, так как весьма трудно догадаться, какие именно объемы информации собирается передавать устройство (плюс еще и удаленное обновление программного обеспечения). Более дешевый вариант от китайского noname производителя будет стоить почти шесть сотен гривень. Управление здесь будет происходить только при помощи звонков с предустановленного номера либо SMS-сообщений. Особенно внимательный зритель на фотографии внутренностей устройства увидит останки мобильного телефона Siemens предположительно A- или C- серии, которым китайский производитель даровал вторую жизнь. Это далеко не все предложения, но у меня ведь не обзор только розеток, поэтому на этом тему закроем.

Второй интересный вариант — это сетевой фильтр с удаленным управлением. На сегодняшний день представлен на нашем рынке моделью Energenie EG-PMS2-LAN. По цене мало чем отличается от GSM-розетки, но, конечно, поинтереснее. Для начала сразу скажу, что здесь уже не одна розетка и не три, а целых шесть. Управление происходит через веб-интерфейс, где по одному клику можно либо отключить определенную розетку, либо дать на нее питание. Не поможет в случае зависания роутера, зато очень даже неплохо для хозяйства, так как кроме указанной мною цели может пригодиться, например, для обогрева помещения (включать обогреватель за полчаса до прихода с работы), для освещения (включить внешнее освещение перед приходом) или для других хозяйственных целей. Это, пожалуй, мой фаворит, за одним только исключением — по данным сайта в моем городе данным устройством торгует сразу шесть магазинов, но вот незадача, никогда я его в этих магазинах не видел (а ко всему, что имеет ethernet-интерфейс я прилипаю сразу же). А еще не очень хорошо понятно, что будет в случае потери питания. Есть ли у сетевого фильтра своя память, или после восстановления питания все подключенные устройства будут автоматически запущены?

ИБП с удаленным управлением. Производители ИБП (даже дорогих) почему-то не видят никакой необходимости в удаленном управлении, поэтому единственная модель, которую мне удалось найти — это APC Back-UPS HS 500VA, которая в последний раз в продаже была в апреле сего года и с тех пор снята с производства. А зря, достойное устройство. Никаких аналогов мне найти не удалось даже в ценовой категории over 3000, и это при том, что указанная модель стоила всего-то 1700 гривень. Единственный вариант — искать такую штуку на вторичном рынке, либо в таких магазинах, где она могла еще заваляться с тех пор, когда была в моде. Надеюсь, кто-нибудь из производителей когда-нибудь выпустит аналог.

Порно-вариант. Многие ИБП управляются через USB/COM -порт. При этом можно попытаться каким-то извращенным способом подключить ИБП через переходник на ethernet к роутеру, задать ему внешний порт, на который попытаться отправить команды с компьютера. Штука весьма иллюзорная, так как, скорее всего, подключенный к роутеру ИБП даже не опознается роутером и будет признан просто отключенным портом, но любителям экспериментов рекомендую.

Вот, какого прогресса мы добились за десятилетия существования компьютеров. Даже перезапустить зависший сервер удаленно без существенных капиталовложений не получится.


blog.ibice.ru

Устройства управления питанием — Удаленное управление питанием через Сеть PN7212G-AX

ALTUSEN PN7212является 12 -портовым распределителем электропитания устройств (PDU) серииPower Over the NET™. Устройство имеет 12 управляемых розеток электропитания с возможностью удаленного доступа к ним. Это позволяет IT администраторам контролировать электропитание, подключенных к PN7212, устройств из любой точки мира, где есть подключение к Интернету по протоколу TCP/IP. (Подобные устройства называют также Панелями Распределения Электропитания — ПРЭ).

Возможность измерения параметров потребления электроэнергии в реальном времени, позволяет администраторам контролировать напряжение и потребляемую IT оборудованием мощность как на уровне отдельной розетки, так и на уровне всего блока розеток. Это помогает минимизировать эксплуатационные затраты и обеспечивает высокий уровень надёжности и доступности систем в серверных любого масштаба.

Устройство PN7212 лучшим образом подходит для серверных и ЦОД с высокой плотностью установки серверов. С целью экономии места в стойке, устройство выполнено в форм-факторе 0U. Конструкция обеспечивает возможность крепить устройство вертикального за пределами рабочего пространства стойки, что значительно экономит место для размещения дополнительных серверов и предохраняет силовые кабели от повреждения.

Функция измерения параметров в реальном времени в сочетании с системой оповещения о превышении значений параметров информирует вас о рабочем состоянии всего, подключенного к системе, оборудования. Тревожные сообщения, содержащие описание произошедших аварийных событий, могут рассылаться через почтовый сервер SMTP или в виде SMS через порт Digital Output. PN7212 также имеет порты для подключения сенсоров для мониторинга температуры и влажности. По этим параметрам так же могут генерироваться тревожные сообщения. IT администраторы могут легко контролировать электропитание подключённых устройств и управлять устройствами, при необходимости – удаленно с помощью Пользовательского интерфейса в браузере. Это оптимизирует затраты на поддержку оборудования в серверных или ЦОД, которое доступно 24 часа в сутки 7 дней в неделю.

PN7212 легко каскадируются для управления большим количеством устройств. Таким образом, ваша система управления серверными может расти вместе с ростом вашей компании. Для упрощения задач по управлению, система управления устройствами, позволяет комбинировать их с другими продуктами ALTUSEN*, администраторы могут работать с ними через общий интерфейс для управления. Когда устройства интегрированы в систему управления CC (Control Center Over the NET™), силовая розетка для IT устройства может ассоциироваться с портом KVM и отображаться на одной ВЕБ странице. Это позволяет IT администраторам полностью управлять IT устройством из единого пользовательского интерфейса *KVM Over the NET™ .

S/N: PN7212G-AX; PN7212G; PN-7212; PN7212

 

Особенности:

 

Распределение мощности.

  • Максимальная нагрузка / Выход: NEMA 20A / 12 розеток; IEC 16A / 12 розеток.
  • Экономия пространства, устройство занимает 0U в стойке.
  • Возможна установка разъемов стандартов IEC или NEMA.
  • Последовательное подключение до 15 дополнительных станций позволяет управлять 192 розетками.
  • 2 х 7-сегментный индикатор на передней панели показывает позицию подключения станции и номер розетки.
  • Автоматический предохранитель с функцией восстановления PDU.
  • Удаленные пользователи могут контролировать состояние розеток через Интернет- браузеры.
  • Поддержка “мягкого “отключения серверов (Shutdown).
  • Раздельное электропитание устройства и нагрузки. Пользовательский интерфейс доступен даже в случае срабатывания автомата защиты.

 

Удаленный доступ.

  • Удаленное управление питанием через TCP / IP и встроенный 10/100 Ethernet порт.
  • Альтернативное управление через модем.
  • Сетевые протоколы и интерфейсы: TCP / IP, PPP, UDP, HTTP, HTTPS, SSL, SMTP, DHCP, ARP, NTP, DNS, Telnet, 10Base-T/100Base-TX, Auto Sense, Ping
  • Поддержка IPv6

 

Работа.

  • Локальное и удалённое управление розетками (Вкл, Выкл, Перезагрузка в цикле), каждой в отдельности или группами.
  • Поддержка объединения розеток в группы, распределенных по каскаду устройств – определенные действия могут выполняться с группами розеток одновременно.
  • Поддержка управления устройств (серверов) с резервированным электропитанием при помощи каскадирования устройств и группировки розеток.
  • Временные графики Вкл/Выкл для отдельных розеток и групп. Задачи по управлению электропитанием могут выполняться на базе дневных, недельных, месячных или, определяемых пользователем, календарных графиков.
  • Поддержка нескольких методов управления питанием – Wake on LAN, System After AC Back, Kill the Power.
  • Очередность включения – пользователь может настроить очерёдность включения и время задержки для каждой розетки таким образом, чтобы включение оборудования происходило в правильном порядке(определенной последовательности).
  • Легкая настройка и экспуатация через пользовательский интерфейс в интернет — браузере.
  • Поддержка различных браузеров (IE, Mozilla, Firefox, Safari, Opera, Netscape).
  • Доступ посредством Telnet и SSH к текстовому меню для конфигурации, управления розетками и мониторинга.
  • Поддержка локальной консоли доступа.
  • Для работы без браузера — Java GUI ПО в комплекте.
  • Поддержка RTC(часов реального времени)— таймеры не сбрасываются при отключении устройства от электропитания.
  • До 64-х учетных записей – до 32-х одновременных подключений

 

Управление.

  • Измерение параметров электропитания на уровне отдельной розетки и устройства в целом.
  • Светодиодная индикация тока, напряжения и рассеиваемой мощности на уровне розетки и всего устройства; температуры и влажности среды.
  • Отображение в режиме реального времени, в браузере: напряжения; рассеиваемой мощности; потребления электроэнергии, для отдельной розетки, группы розеток, всего устройства и устройств в каскаде.
  • Мониторинг окружающей среды – поддержка внешних сенсоров температуры, температуры/влажности для мониторинга температуры м влажности в стойках.
  • Установка триггеров, срабатывающих по превышению заданных значений по току, напряжению, рассеиваемой мощности, потребляемой электроэнергии, температуре и влажности.
  • Оповещении о срабатывании триггеров по избрианным событиям (Вкл, Выкл, Перезагрузка по циклу, Отклонение от допустимых параметров и.т.д.), посредством звукового сигнала, мигающих индикаторов (локально), SMTP, SNMP оповещения, и через порт digital output.
  • Поддержка наименования портов и групп портов.
  • Права доступа пользователей для каждой розетки отдельно.
  • ПО log- сервера — под ОС Windows; регистрация событий на устройстве, поддержка syslog.
  • Интеграция с ПО управления ALTUSEN CC2000 и с KVM устройствами ATEN; API для интеграции с приложениями управления и контроля 3-х производителей.
  • Обновляемая прошивка микрокода – каскадированные устройства получают прошивку с головного устройства по шине каскадирования.
  • Мультиязыковая поддержка: Английский, Немецкий, Традиционный Китайский, Упрощенный китайский, Японский, Корейский, Русский

 

Безопасность.

  • Трёхуровневый парольный доступ.
  • Фильтрация по IP/MAC.
  • Шифрование 128-bit SSL.
  • Поддержка внешней аутентификации: RADIUS, TACACS+, LDAP, LDAPS и Active Directory.

 

Комплектация:

  • 1х 12-розеточное устройство Power Over the NET™;
  • 4x Serial адаптеры1x SA0142 (RJ45F к DB9M)1x SA0149 (RJ45F к DB9F)1x SA0150 (RJ45F к DB9M)1x SA0151 (RJ45F к DB9F)
  • 2х Комплект для монтажа в стойку: кронштейны и крепления;
  • 1x Провод заземления
  • 1х Инструкция по эксплуатации;
  • 1х Компакт-диск с ПО;

Спецификация

 

Параметр

Значение

Розетки питанияНепосредственно на устройстве12
Максимально192 (при каскадировании)
РазъемыВход электропитанияNEMA1 x NEMA L5-20P
IEC1 x IEC 60309
Выход электропитанияNEMA12 x NEMA 5-15R
IEC12 x IEC320 C13
PON Вход /Консоль1 x RJ-45 (розеточный)
PON Выход1 x RJ-45 (розеточный)
Модем1 x RJ-45 (розеточный)
Сеть1 x RJ-45 (розеточный)
Подключение сенсоров2 x RJ-11 (розеточный)
Цифровой выход1 x RJ-45 (розеточный)
ИндикаторыID1 x 2-цифры 7-сегментов
Станции1 (Зеленый)
Розетки1 (Зеленый)
Считывания1 x 3-цифры7-сегментов
Тока1 (Зеленый)
Напряжения1 (Зеленый)
Питания1 (Зеленый)
Сенсора 11 (Зеленый)
Сенсора 21 (Зеленый)
Ограничение по току (Всего по входу)NEMA100-120В; 50/60Гц; 16A
IEC200-240В; 50/60Гц; 16A
Максимальная нагрузкаNEMA120В; 50/60Гц; 1920Вт
IEC230В; 50/60Гц; 3680Вт
Ограничение по токуна портNEMA100-120В; 50/60Гц;
12A
IEC200-240V; 50/60Hz; 10A
ВсегоNEMA200-240В; 50/60Гц; 15A
IEC200-240В; 50/60Гц; 15A
Потребляемая мощностьNEMA120В; 50/60Гц; 16Вт
IEC230В; 50/60Гц; 18Вт
Окружающая средаРабочая температура0-50C
Температура хранения20-60C
Влажность0-80% относительная, без конденсата
Физические характеристикиМатериал корпусаМеталл
Вес4.49 кГ
Размеры ( Д x Ш x В )6.42 x 5.46 x 134 см

sfpspb.ru

Обзор возможностей удаленного управления питанием по IP с оборудованием KVM Aten

Отвечая постоянно растущим запросам глобализированной экономики и Интернета, KVM-решения приобретают в настоящее время функциональные возможности IP-взамодействия, что делает возможным удаленное управление и лучше удовлетворяет требованиям корпораций, которые нуждаются в контроле над работой серверных помещений в разных частях света. Фактически уже можно реализовать решения, устанавливающие полный контроль над  удаленными компьютерами, используюя KVM  оборудование компании Aten International.

Отвечая постоянно растущим запросам глобализированной экономики и Интернета, KVM-решения приобретают в настоящее время функциональные возможности IP-взамодействия, что делает возможным удаленное управление и лучше удовлетворяет требованиям корпораций, которые нуждаются в контроле над работой серверных помещений в разных частях света. Фактически уже можно реализовать решения, устанавливающие полный контроль над  удаленными компьютерами, используюя KVM  оборудование компании Aten International.
Устройства управления питанием позволяют управлять режимом электропитания подсоединённого оборудования с компьютера подключённого с сети Интернет, где бы он не находился — в соседнем помещении или на другом конце земного шара.

Устройство ATEN PN9108 позволяет удалённо через TCP/IP соединение управлять режимом электропитания 8-ми розеток, позволяя администратору управлять включением, выключением, перезагрузкой подсоединённого оборудования с компьютера, подключённого к сети Интернет.

Устройство ATEN Altusen PN9108 уже содержит интегрированный модуль управления по IP и порт для подключения в IP сеть.

Пример подключения ATEN Altusen PN9108

PN9108 — Устройство управления электропитанием по RS-232. 
Дистанционное управление 8-ю электророзетками: включение, выключение, корректная перезагрузка.
Управление по RS-232. Возможен доступ к PN0108 по LAN / WAN через устройства CN-6000, PN9108, KN9116, SN0108, SN0116.
Каскадирование до 16 устройств для управления 128 выходами питания.
Защита паролем.    

 

ATEN Altusen PN9108   позволяет производить:
  • безопасное выключение (Safe Shutdown) и перезагрузка для Windows систем;

  • включать и выключать электропитание устройств;

  • программировать штатные и аварийные режимы электропитания.

  • измерение совокупной нагрузки, просмотр информации о нагрузке в амперах с помощью GUI;

  • группирование портов: выполнение одного и того же действия над указанной пользователем группой портов.

  • Устройство управляется по IP и имеет резервное управление по RS232.

 

 

 

 

 

 

 

Устройство ATEN Altusen PN0108 при совместном использовании с соответствующим оборудованием ATEN или Altusen, которое работает по протоколу TCP/IP (PN9108, CN-8000, SN0108/ SN0116, Aten — ALTUSEN KN2116 /Aten — ALTUSEN KN9108 /Aten — ALTUSEN KN9116, KL9116, Aten — ALTUSEN Kh2508i), позволяет администратору удалённо управлять электропитанием подсоединённого оборудования с компьютера, подключённого к сети Интернет.

Пример схемы подключения ATEN Altusen PN0108


 

Также устройство ATEN Altusen PN0108 позволяет производить:

  • безопасное выключение (Safe Shutdown) и перезагрузку для Windows систем;

  • группирование портов: выполнение одного и того же действия над указанной пользователем группой портов.

 


Управления подачей электропитания ALTUSEN PN0108

 

SN0108/SN0116 — консольные  сервера Altusen SN0108/SN0116  — Устройства доступа к RS-232 портам по TCP/IP. Устройства «доступа к последовательным портам по сети™» представляют собой управляющbе устройства, которsе обеспечивают удаленный доступ к 8/16 независимым последовательным портам (серверам, сетевым концентраторам, маршрутизаторам, устройствам управления электропитанием и другим IT-устройствам) через соединение по протоколу TCP/IP. До 16 пользователей могут одновременно входить в систему с любого компьютера, подключенного к интернету, где бы он ни находился в соседнем помещении или в любой точке планеты. Каждый из пользователей может управлять любым (но одним!) свободным портом. Для перехода к управлению другим портом, порт должен быть освобожден.

Удаленный доступ к 8/16 устройствам с интерфейсом RS-232.
Поддержка протоколов TCP/IP, UDP/IP, Telnet, SSH, SSL и PPP.
Защита паролем и шифрованием.

 

Схема подключения SN0108/SN0116

 

Коммутационные устройства CN-6000 — KVM-удлинитель по TCP/IP.

 CN-6000 позволяет отдалить рабочее место оператора (монитор, клавиатура, мышь) от системного блока компьютера на неограниченное расстояние.
Возможно подключение к KVM-переключателю для управления группой компьютеров (серверов).
Разрешение до 1600 х 1200 при 60 Гц.
Защита паролем и шифрованием.

Удлинитель/IP KVM шлюз, SVGA+KBD+MOUSE PS/2, управление по IP, Rackmount/Desktop, 10/100 Base-T, с KVM-шнуром PS/2 1.2м., TCP/IP, (WIN98SE/ME/2000/XP/FREE-BSD/LINUX 7.0 или выше;1600×1200 60Hz;ALTUSEN;DKVM-IP1;LKV-IPM01;

Диаграмма подключения  CN-6000

Отвечая постоянно растущим запросам глобализированной экономики и Интернета, KVM-решения компании  ATEN International Co. Ltd. приобретают в настоящее время функциональные возможности IP-взамодействия, что делает возможным удаленное управление и лучше удовлетворяет требованиям корпораций, которые нуждаются в контроле над работой серверных помещений в разных частях света.

 

www.insotel.ru

Обновлено: 03.08.2019 — 00:12

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *